MTscan – sniffer mode (tzsp)

In order to run MTscan the in the sniffer mode (tzsp), the packet streaming must be configured on the Mikrotik device.

This can be done in one of two ways.

  • First way: via SSH command line

    /interface wireless sniffer set multiple-channels=yes streaming-enabled=yes streaming-server=PUT_YOUR_IP

    Optionally you can also modify the channel time for faster channel hopping (e.g. 100 ms / freq).

    /interface wireless sniffer set channel-time=100ms

  • Second way: via Winbox

    1. Open Wireless window
    2. Double click the wireless interface (e.g. wlan1)
    3. Click the Sniff… button
    4. Stop the sniffer if it is already running
    5. Click the Settings button
    6. Tick the Multiple Channels checkbox
    7. Tick the Streaming Enabled checkbox and provide your IP address in the Streaming Server input
    8. Save the settings by clicking OK.

    Optionally you can also modify the channel time for faster channel hopping (e.g. 00:00:00.1 for 100 ms / freq).

Known issues

  • The reported frequency is incorrect below 5000 MHz due to limitations of the TZSP protocol, as the 8-bit integer Channel Tag is nondeterministic. For example, channel 48 points to both 4985 MHz and 5240 MHz frequencies. This issue has been reported to MikroTik support in 2017 and acknowledged, but with no solution. Similarly, this problem also affects the 2 GHz band beyond the 2.4 GHz.
  • TZSP protocol does not carry any information about frequency band or channel width. These values must be predefined in the MTscan settings (TZSP tab).
  • MTscan in the sniffer mode binds to the UDP 37008 port (default). In order to run more than one instance of MTscan in sniffer mode at the same time use the tzspd (tzsp repeater) and change the port in settings (TZSP tab). 
  • Fast channel hopping is unreliable on devices based on AR93xx chipset. The radio calibration process takes around 100 ms for each channel. During that time, all reported signals level values are underestimated and the sensitivity is considerably worse. The workaround is to use longer channel hopping time (at least 200 ms/freq, preferably more). This problem has been reported to MikroTik support in 2018 and acknowledged, but also with no solution.

RouterOS version 6.41 or later is required for the sniffer mode.